Issues installing ShinyPsych package

Hello everyone, i'm having problems installinh ShinyPsych in my computer. I already try a lot of different ways to install, had updated all my packages and still i'm getting an error.
I have all necessary packages installed (at least the log tell nothing about it).

My sessionInfo is:

The code i used to install is:


And the error i'm receiving is:


The strange thing is that i have already installed the package in another machine.

Any suggestions? Thanks.

What versions of RStudio and Pandoc do you have installed? There are some known issues with windows 10 and pandoc that were solved in the preview version of RStudio, you could give it a try.

I will check it out, thank you! I have the latest version of Rstudio, about the pandoc i honestly don't know. I will check that too.

I have just installed version 2.7.2 of pandoc. The RStudio version is 1.2.1335.
I'm still getting the same error =/.
I also try by a different repository:

devtools::install_github("ndphillips/ShinyPsych", build_vignettes = TRUE)

whitout success. This last one dont even start to build the vignettes.

As I said before, there are known issues with that pandoc version on windows, try installing the preview version of RStudio 1.2.1522 (not the latest stable one) because it comes with a custom version of pandoc that solves those issues.

Did not work =/ I must do something after installing RStudio? Or just install the new version and try to install the package again?

Do you have a separate pandoc installation? If so try uninstalling it first.
You need to use the one that comes bundled with the preview version of Rstudio

I had, but i uninstalled both pandoc and RStudio and installed RStudio again. But the error insist.
This could has something to do with Rtools?

Just to be clear what version of Rstudio you have installed?

I don't think so, the error message you are showing suggests that there is a pandoc problem

This error from the second installation is:

1.2.1522. Its the right one, right?

That is a different issue and it has to do with permissions. Are you running Rstudio as administrator? Have you tried manually deleting that folder before installing again?

Yes i guess that second installation code dont work anymore.
The installation i had success was with the first code..
Which folder you mean? The Rstudio one? I did it now and just installed again. Not work

The one that appears in your error message after "cannot open file"

You should paste the actual error message here instead of screen shots that way it would be easier to help you.

I sent a message to the creator of the package. He updated the VignetteIndexEntry lines in the vignettes. The vignettes are now being created ok. I'm now receiving the following error:

Downloading GitHub repo mdsteiner/ShinyPsych@master
√  checking for file 'C:\Users\Acácio Mattos\AppData\Local\Temp\RtmpwlhFtr\remotes21f437ae73c7\mdsteiner-ShinyPsych-849c776/DESCRIPTION' (798ms)
-  preparing 'ShinyPsych': (2.1s)
√  checking DESCRIPTION meta-information ... 
-  installing the package to build vignettes (807ms)
√  creating vignettes (28s)
-  checking for LF line-endings in source and make files and shell scripts (2.3s)
-  checking for empty or unneeded directories
-  building 'ShinyPsych_0.2.3.tar.gz'
Installing package into ‘C:/Users/Acácio Mattos/Documents/R/win-library/3.6’
(as ‘lib’ is unspecified)
* installing *source* package 'ShinyPsych' ...
** using staged installation
Error in file(file, if (append) "a" else "w") : 
  (converted from warning) cannot open file 'C:/Users/Acacio Mattos/Documents/R/win-library/3.6/00LOCK-ShinyPsych/00new/ShinyPsych/DESCRIPTION': No such file or directory
ERROR: installing package DESCRIPTION failed for package 'ShinyPsych'
* removing 'C:/Users/Acácio Mattos/Documents/R/win-library/3.6/ShinyPsych'
Error in i.p(...) : 
  (converted from warning) installation of package ‘C:/Users/ACCIOM~1/AppData/Local/Temp/RtmpwlhFtr/file21f45a24d33/ShinyPsych_0.2.3.tar.gz’ had non-zero exit status

Done Andrés! I change the library and it works! Probably if have done this before the creator could not even updated the vignettes. Anyway, i try this after reading this post:

Maybe that solve any kind of installation problems when the DESCRIPTION file dont find "such directory"

Thanks for the patience!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.