issues installing rlang on windows 10

I have been able to install the development version of tidyr on my Ubuntu virtual machine, but I am having nothing but problems trying to get it installed on my main Windows 10 machine. One evidently needs a version of rlang to be able to download the development version of rlang from git-hub. So I cleaned rlang out of my private R library, installed the current standard version from an R repo, restarted R as administrator, and then tried the following, with the following results:

R version 3.6.0 (2019-04-26) -- "Planting of a Tree"
Copyright (C) 2019 The R Foundation for Statistical Computing
Platform: x86_64-w64-mingw32/x64 (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

[Workspace loaded from ~/.RData]

> devtools::install_github("r-lib/rlang", build_vignettes = TRUE)
Downloading GitHub repo r-lib/rlang@master
√  checking for file 'C:\Users\lhunsicker1964\AppData\Local\Temp\RtmpMxTbnK\remotes35b42c1a66a7\r-lib-rlang-6a232c0/DESCRIPTION' (1.1s)
-  preparing 'rlang': (1.7s)
√  checking DESCRIPTION meta-information ... 
-  cleaning src
-  installing the package to process help pages (1.1s)
-  cleaning src (28s)
-  checking for LF line-endings in source and make files and shell scripts (621ms)
-  checking for empty or unneeded directories (637ms)
-  building 'rlang_0.3.4.9003.tar.gz' (341ms)
Installing package into ‘C:/Larry/R/win-library/3.6’
(as ‘lib’ is unspecified)
* installing *source* package 'rlang' ...

R then hung for at least 10 minutes. This has happened now three times.
Any suggestions why R is hanging, and what I can do to update rlang to the current developer version, so that I can update tidyr and use the unnest_wider() function?

Addendum: This appears to be an R problem, not an RStudio problem, as the same thing happens when I run native R.

Try to use remotes::install_github("r-lib/rlang") ?
Based on this,

On Windows DLL can't be copied over if they are in use. Close all your R and RStudio sessions, and install rlang with the {remotes} package, which doesn't depend on rlang and thus won't load it in your session.

Hope it could help!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.