Issues installing a number of CRAN packages

Apologies if this has been asked before. I couldn't find a similar topic.

My colleagues and I are using RStudio on Workbench. We have all set up our environments to install packages from CRAN. The problem I'm having is that a number of CRAN packages I've tried to install aren't working. One of them being 'dlookr'. The problem appears to be that a lot of dependencies don't seem to be available. This is not a problem for my colleagues, and no-one on-site can help me.

Here's what I've tried so far:

  • Updating the version of R I use from 4.3.2 to 4.3.3
  • Manually installing dependencies
  • Adjusting the primary CRAN repository from 'Global (CDN) - RStudio' to our CRAN repository URL
  • Cleared package caches of all dependencies

Does anyone have any suggestions?

It's difficult to say what the problem is without seeing the error messages you're encountering. If your colleagues aren't having the same issue, then you may want to check whether you have any state in your user level .Rprofile or .Renviron that's affecting your environment. One thing I try when debugging environments is creating an isolated environment with renv and installing the package there.