Issue with R Studio Server AD authentication for privileged account

We are trying to setup R Studio Server (free version) and have ran into problems when logging into the page with a privileged AD account. We have setup a virtual Linux server and have installed the following:

  1. yum install R – installed all R packages and dependencies
  2. Followed the steps from this link for RedHat/CentOS 6 and 7

At this time I can access the R Studio sign-in page. Also the server management person who set it up can access the page also and log into the site as well. However I cannot log into the site myself. Please note, for compliance reasons I have to use a privileged AD account instead of my regular one.

The following has been tried to remedy the problem. However without success:

Modified rstudio file at this location/etc/pam.d/ to look like the following:

auth requisite uid >= 500 quiet
auth required
account required

Copied the R directory from server management support person's folder to mine.

Neither of these attempts has fixed it for me.

Please advise.

Hi @kpainter, I believe that only the Professional version of RStudio Server will allow for AD integration: (see the second bullet list)

This is the section where it walks through how to do that with RStudio Server Pro:

If interested, there is a 45-day evaluation license you should be able to use to test the configuration and confirm that it does what you need:

Hope this helps

I would also like to share a great explanation for why some features are only in the professional version of our products:

Thanks for your reply. I will share this with our team.