Issue with R-3.5.0 to install openssl package installation

In our SUSE Linux 11 system, there is a number of R version installed as module avil. Now i installed R-3.5.0 (with the _SL suffix) and update the R-studio server and configure R-studio to use R-3.5.0_SL as default.
Now when user/me try to install Several dependencies, it cannot be installed, for example, the package “openssl”. I get the following error (using the command line R or from R-Studio):

The major difference I found in R-3.5.0 with the existing version. It has new directory lib64. This directory contains R and pkgconfig. I am new in R environment. Is any of you could help me to do the process.

I tried several ways to install (manually download the package and use the local link, "R CMD INSTALL" is not working on our server, don't know as i am new here)

> install.packages('openssl')
 trying URL ''
Content type 'application/octet-stream' length 1194261 bytes (1.1 MB)
downloaded 1.1 MB

* installing *source* package ‘openssl’ ...
** package ‘openssl’ successfully unpacked and MD5 sums checked
------------------------- ANTICONF ERROR ---------------------------
Configuration failed because openssl was not found. Try installing:
 * deb: libssl-dev (Debian, Ubuntu, etc)
 * rpm: openssl-devel (Fedora, CentOS, RHEL)
 * csw: libssl_dev (Solaris)
 * brew: openssl@1.1 (Mac OSX)
If openssl is already installed, check that 'pkg-config' is in your
PATH and PKG_CONFIG_PATH contains a openssl.pc file. If pkg-config
is unavailable you can set INCLUDE_DIR and LIB_DIR manually via:
R CMD INSTALL --configure-vars='INCLUDE_DIR=... LIB_DIR=...'
ERROR: configuration failed for package ‘openssl’
* removing ‘/R/R-3.5.0_SL/lib64/R/library/openssl’

The downloaded source packages are in
Warning message:
In install.packages("openssl") :
  installation of package ‘openssl’ had non-zero exit status

Sorry, but it's unlikely that anyone here will be able to help you debug issues with your system's environment. The error indicates that the openssl R package is unable to locate the requisite openssl system libraries. Does your module make the openssl system library available?

@kevinushey thank you for your response. Yes in our system, already has opnessl installed but I want to install for specific R-3.5.0 version. As we have already several R version. There is no problem if i select other version as module load to install packages. But when i select new version R-3.5.0 and try to install then its throwing this error message. It would be great help if you please write me how to define the system libraries. and one more question, openssl package is same for Python and R?

This is what I did on my machine:

cd ~/lib
tar -xzvf openssl-1.0.2o.tar.gz
mkdir openssl
cd openssl-1.0.2o
./config -fPIC shared --openssldir=$HOME/lib/openssl 
make -j16
make test -j16
make install
echo 'export PATH=$HOME/lib/openssl/bin:$PATH' >> ~/.bash_profile
echo 'export PKG_CONFIG_PATH="$HOME/lib/openssl/lib/pkgconfig:$PKG_CONFIG_PATH"' >> ~/.bash_profile
echo 'export LD_LIBRARY_PATH="$HOME/lib/openssl/lib:$LD_LIBRARY_PATH"' >> ~/.bash_profile
rm ~/lib/openssl-1.0.2o.tar.gz

Replace $HOME with your own home absolute path.

1 Like

@dchiu thank you for your response. While i have one question, openssl package(openssl_1.0.1 for R) and your suggestion openssl-1.0.2o both works as same ? I am confused about that.

The openssl R package is the R interface to using the OpenSSL library. So you see

that OpenSSL is in SystemRequirements which means it is a prerequisite to installing the R package openssl.

@dchiu thank you for the info. So, on our server already installed openssl-1.0.2h.tar.gz (h version) and using in Python. That's not the issue. I need to install the Openssl 1.0.1 as R interface. When i try to install it its throwing that error message. So could you please write the command steps to install and PATH change process. As i mention, an old version of openssl 0.9.8j is installed in our server as default. Now i want to install this particular new version(Openssl 1.0.1) for this particular R version(3.5.0) inside as module load command in Linux. Please consider me as i am new in Linux environment as well as R and Python. Eagerly waiting for your response.

I am running CentOS 5. Have you tried to adapt the commands in my first post for your machine?

@dchiu our server is SUSE Linux 11 system. As i told, openssl-1.0.2h.tar.gz is already installed. So i did not try your last comments. Could you please write about the $HOME and $PATH address for example. You already mention $HOME is the home absolute path. I thought these commands are particularly for openssl-1.0.2o.tar.gz not applicable for R related openssl-1.0.1. If you say its required then i will follow these commands.

So $HOME will be something like /home/dchiu and $PATH is your existing environment path. Since you already have a version of openssl installed on your system you only need to run the echo calls to update your .bash_profile (or .bashrc) with the new environment variables. Run source .bash_profile to ensure variables are updated.

@dchiu Sorry for my late response. I have tried your first post commands but same error comes.

Try posting your question on another forum. The issue appears to be specific to your system environment and not related to R.

1 Like

Hi mos
I have executed the exact steps you have mentioned above.
Im running Redhat 7.2.
The PATH and PKG_CONFIG_PATH are updated accordingly.
Any other idea what could go wrong here ?

A post was split to a new topic: Xml2 package installation issues - pkg-config PATH help