Issue with installation and updating packages

Dear Sir or Madame,

I have installed the latest version of RStudio. However, right from the start it said that some packeges are obsolete and must be updated. And they truly don't work, like 'knitr' or 'rmarkdown'.

However, on the Packages tab when I click the "update" button the Message Box says that all the packages are up to date.

How can this problem be solved?
Is there a way to instruct the RStudio to automatically fix such failires?

Here's what the program says when I try to update its packages:

Is there any specific reason you are using such an old version of Mircrosoft R? You are also using snapshot package that is set to 2016-11-01 when packages that are probably on your computer right now were not yet obsolete.

So, I would suggest to, first, update R version to more recent one, and, second, don't use snapshot package if you are planning to update your packages regularly to the most up-to-date version.

Thank you for your advice. I installed this RStudio today.
All the packages went with it.
It is also very surprising to me, why the latest version is supplied with such old packages... and why after first installation a user must surf the Internet and find clues how to turn a new program into a working instrument...

I just reinstalled R to 3.5. However, now 'knitr' refuses to make PDF. It says it requires a package called: "pdfplatex'. I tried installing it, but now it conflicts with the newly installed R.

Installing package into ‘C:/Users/Admin/Documents/R/win-library/3.5’
(as ‘lib’ is unspecified)
Warning in install.packages :
package ‘pdflatex’ is not available (for R version 3.5.0)

Any ideas how to solve it? Thanks in advance!

There's no spesific reason for an old version of R, it went with Anaconda Navigator 3, I installed a long time ago mainly for Python. I started a new course in statistics this week and all the tasks are in R wich I am quite unfamiliar with. In order to pass the test I have to complete exercises in R in rmarkdown, but mine doesn't work, since I never user RStudio before and it became obsolete.

Today I installed the latest RStudio, but the problem only doubled...

I'm not familiar with how process works with Anaconda, so don't have any good advice there. In general, installing R on it's own tends to be fairly uneventful. One thing that you've came across is that current version (3.5.0) changed quite a few things, so not all packages updated yet. I would recommend for now to use 3.4.4 (previous version).

Also, just to make sure we are on the same page, RStudio and R are not the same thing. So, when you say that you've updated RStudio to the latest version you probably mean R. This thread should help:

Finally, are you sure that knitr is telling you to install pdflatex? I've checked my installation and I don't have this package and I can assure you that I'm using knitr quite a bit without it.

@DmitryBriukhanov To knit to PDF on Windows, you'll need a TeX distribution, which you can install using a separate program called MiKTeX (

Once you do that, you'll be able to knit to PDF. You want to make sure that "automatically install missing packages" in MiKTeX is checked.


Thank you for your kind advice. I tried it. Here's what I got:

Installing package into ‘C:/Users/Admin/Documents/R/win-library/3.5’
(as ‘lib’ is unspecified)
Warning in install.packages :
  package ‘MiKTeX’ is not available (for R version 3.5.0)

Miktex isn’t an R package. Like @terence said, you can get it from the website

1 Like

There is also TinyTeX. It is quite small, so should be easy to install without too many issues.

And since honestly sorting out all these system dependencies is confusing, I’ll point out that tinytex is an R package that contains tools for installing a custom LaTeX distribution based on TeXLive that’s designed to make all this as (hopefully) painless as possible. At this point, if you don’t have pre-existing LaTeX experience and opinions about what you want in your LaTeX distribution, I’d always start with tinytex.


That's good to know. Thanks @jcblum! I'll try this when I teach my course again this fall.

1 Like

The problem here is, because you're using an old version of R, binaries are no longer being produced and so, for example, stringr 1.1.0 is the latest (binary) version of that package. You can force RStudio to attempt to use the source repositories with something like:

options(pkgType = "source")

although note that this will require Rtools for installation of packages from sources.

1 Like