issue installing latest version of quanteda

I started a new project ( and can't seem to be able to install the quanteda package. The installation fails while compiling. I have the package running on another project, but a new version came out just yesterday and won't install. I tried installing the previous version install_version("quanteda", version = "2.0.1", repos = "") but it doesn't seem to work.

Any thoughts on why this might be happening?


g++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-5/README.Bugs> for instructions.
make: *** [tokens_segment_mt.o] Error 4
/opt/R/4.0.0/lib/R/etc/Makeconf:176: recipe for target 'tokens_segment_mt.o' failed
ERROR: compilation failed for package ‘quanteda’

  • removing ‘/home/rstudio-user/R/x86_64-pc-linux-gnu-library/4.0/quanteda’
    Error: Failed to install 'unknown package' from URL:
    (converted from warning) installation of package ‘/tmp/Rtmph6bbXV/remotes1a466180eda/quanteda’ had non-zero exit status

This happens from time to time when a new package version is out, the reason is that the package requires more than 1GB of memory to compile (the current RStudio Cloud memory limit), the way RStudio Cloud addresses this issue is by caching precompiled binaries of the packages but it could take some time for the cache to update to the current package version.

Oh, thanks! Do you know if there's any way I can install the cached version?

I am considering using RStudio Cloud for teaching a class, but I need Quanteda, and I keep getting the same error:

installing to /home/rstudio-user/R/x86_64-pc-linux-gnu-library/4.0/00LOCK-quanteda/00new/quanteda/libs
** R
** data
*** moving datasets to lazyload DB
** inst
** byte-compile and prepare package for lazy loading
ERROR: lazy loading failed for package ‘quanteda’

  • removing ‘/home/rstudio-user/R/x86_64-pc-linux-gnu-library/4.0/quanteda’
    Warning in install.packages :
    installation of package ‘quanteda’ had non-zero exit status

Any idea when this will be solved?

You can install the cached version using this repo

remotes::install_version("quanteda", version = "2.0.1", repos = '')
1 Like

This is a life-saver! Thanks a lot!

Please use instead of demo.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.