Installing RStudio on deepin linux


I recently switched to deepin linux from Ubuntu. Deepin is a debian based distribution. I have tried installing RStudio but with no success. after installing r-base and r-base-dev i try installing aan rstudio deb file. This all passes without errors. However if I then try to run rstudio, nothing happens. If I try rstudio from the command line I get

rstudio: /lib/x86_64-linux-gnu/ versionCXXABI_1.3.11' not found (required by rstudio)`

I then tried installing listdc++6 but already have the latest version installed. I tried purging then re-installing all and adding apt-get install -f in the hope it might miraculously fix any missing dependencies but to no effect.

Deepin doesn't have much of a community yet so I wonder if anyone here has any clues as to how to move forward?

(in the meantime I'm moving my projects to our rstudio server).

Thanks in advance,


Do you have gcc or g++ installed? Seems like this is an issue that's mostly a problem for compilers. Rstudio might be making sure it has a suitable tool chain for building packages from source.

Yes. I thought of this but a quick which confirms that I have both installed.

Hi Jim,

I had the same problem with Deepin. This worked for me:

Thannks! That worked first time.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.