Installing RStudio and yaml error messages

Having some issues helping a colleague at work install RStudio. She was getting the following error message whenever she opened up the programme and when trying to install new packages.

Error in yaml.load(readLines(con), error.label = error.label, ...) : 
    object 'C_unserialize_from_yaml' not found
Error in yaml.load(readLines(con), error.label = error.label, ...) : 
    object 'C_unserialize_from_yaml' not found

We've tried uninstalling the yaml package (which resulted in a different error message about the package not existing, as expected), reinstalling it (brought back the old message), installing older versions of it (same error message). Also reinstalled RStudio, both current and previous versions, but got the same error message.

R version is 3.4.3, RStudio is 1.1.423 for Windows and yaml version that was originally installed was 2.1.16. Not sure if it's relevant, but we are on work laptops that require us to install new programmes (and in the case of R, packages) into C:\Users\NAME\Desktop\My Software. Given uninstalling and reinstalling various versions of RStudio and the package hasn't solved the problem, it feels like that might be the cause. But then we've never come across the issue before, so I'm a little stumped.

Any help greatly appreciated.



I've moved this to General as I don't think this is an IDE-specific issue.

If you're attempting to reinstall packages on Windows, make sure you do so in a clean R session -- otherwise, loaded DLLs can get 'stuck' and you'll end up with a mixture of old and new components after the attempted package installation.

Hopefully, restarting R (and making sure you don't have a .Rprofile or similar that loads packages on startup) and reinstalling yaml should get you out of this hole.


> packageVersion("yaml")
[1] '2.1.16'
> ls(envir = asNamespace("yaml"))
[1] "as.yaml"                 "C_serialize_to_yaml"
[3] "C_unserialize_from_yaml" "read_yaml"
[5] "write_yaml"              "yaml.load"
[7] "yaml.load_file"

So those symbols should definitely be provided by yaml 2.1.16. You might also want to make sure you're loading the version of yaml that you're expecting (what does packageVersion("yaml") report for you after installation?)