Installing readxl, tidyveerse and devtools

Using RStudio Version 1.1.447 with R version Rx64 3.3.2. I'm trying to install readxl and it says I don't have permision to do so. It also says the same for installing tidyverse. I also tried to install devtools and wasn't allowed. Any ideas on how to install them?
Thank you

Could you provide a reproducible example (reprex) of your attempt to install these packages? Being explicit about the code you tries to run and the exact messages you received will be informative to folks who can help.

Also could you provide a little system information:

  • RStudio Edition: (Desktop or Server)
  • RStudio Version:
  • OS Version:
  • R Version:
  • Your sessionInfo():

Having asked for all that, my best guess is that you're on windows and you are working a non-admin, limited user. If that's the case, be sure your user had the appropriate permissions. The easy solution is to install as admin.

Hello Curtis
Thank you for answering my post. I am a beginner and was really enjoying the course until this happened.

RStudio - Desktop, RStudio Version 1.1.453, Windows 10, R 3.5.0

The course wanted me to install readxl. Everytime I tried I got the same error message.

Error in install.packages : cannot open file 'C:/Users/Wayne/Documents/R/win-library/3.5/file30d82ee65622/assertthat/DESCRIPTION': Permission denied

Same problem with installing devtools, tidyverse

It seems that R when installing has put a folder in the My Documents folder and it won't give me permission. I have admininstration rights for me and everyone (desperate attempt).

I would appreciate any advice you could give me. Again, thank you for answering my post

Solved. It was Bitdefender that was blocking me. Had to disable the firewall. Works great now.
Thank you all

1 Like

Thank you Curtis for the help. It turned out to be my antivirus - Bitdefender. Had to turn off the firewall.