Installing packages on MacBook - unable to access index for repository cannot open URL ''

Error Information:

Warning in install.packages :
unable to access index for repository
cannot open URL '...../PACKAGES'

Steps taken so far -
Trying to install any package in RStudio or R Terminal using install.packages("ggplot2")
I get the about error messages.

I have tried disabling "Use secure download method for HTTP" in the Tools -> Global Options -> Packages
I have tried changing different CRAN Repositories.
I have tried install.packages('ggplot2', dependencies=TRUE, repos='....')

It's as if R is using a proxy?
I am not behind a firewall, but working from home.

If I put the URLS which R Studio is failing to open into the browser ( I get a response, so Its R Studio and R not connecting to the internet.

Old posts talk about disabling useProxy setting, but in the current version of R Studio this option doesn't seem to exist.

System Information:

  • RStudio Edition: Desktop
  • RStudio Version: 1.2.1335
  • OS Version: MacOs Mojave Version 10.14.6
  • R Version: 3.6.1
  • Disabled Antivirus
1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.