installing packages after update to 3.6

Hi everyone, I updated R to 3.6.0 on my Mac OS X 10.11 and I now fail to load packages both on R and RStudio. I get the following error message

Error: package or namespace load failed for ‘forecast’ in dyn.load(file, DLLpath = DLLpath, ...):
unable to load shared object '/Library/Frameworks/R.framework/Versions/3.6/Resources/library/Rcpp/libs/':
dlopen(/Library/Frameworks/R.framework/Versions/3.6/Resources/library/Rcpp/libs/, 6): Symbol not found: ___cxa_uncaught_exceptions
Referenced from: /Library/Frameworks/R.framework/Versions/3.6/Resources/lib/libc++.1.dylib
Expected in: /usr/lib/libc++abi.dylib
in /Library/Frameworks/R.framework/Versions/3.6/Resources/lib/libc++.1.dylib

Everything was working fine before the upgrade to R 3.6.
Thanks in advance for helping.

Try updating your packages with checkBuilt=TRUE

update.packages(checkBuilt=TRUE, ask=FALSE)

Tried that already, but doesn't work.

Have you tried reinstalling Rcpp package?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.