Installing package microbiomeutilities

Hey, I am new to R. I am a student working on a microbiome project and using a script provided by my supervisor.
I need to install the microbiomeutilities package. I've been trying for quite some time but haven't been successful so far. I think the first issue was that I didn't have the microbiome package installed.
This is the error message I got: ERROR: dependency 'microbiome' is not available for package 'microbiomeutilities'. Based on this I thought that maybe installing that would solve my issue.

However, I got a new error message:

Error: package or namespace load failed for 'microbiome' in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
namespace 'vctrs' 0.5.0 is already loaded, but >= 0.5.2 is required
Execution halted
ERROR: lazy loading failed for package 'microbiomeutilities'

  • removing 'C:/Users/c/AppData/Local/R/win-library/4.2/microbiomeutilities'
    Warning message:
    In i.p(...) :
    installation of package ‘C:/Users/c/AppData/Local/Temp/Rtmpuu1kD2/file60022ec7d76/microbiomeutilities_1.00.17.tar.gz’ had non-zero exit status

I would love some help on this as I'm really inexperienced and don't want to bother my supervisors with minor issues.
Thank you!

Hi welcome to the Forum.

Your immediate problem is that your {vctrs} package is outdated and R cannot install a new version while 'vctrs` is loaded.

Restart **R ** and RStudio and do


and retry the installation

1 Like

Oh thank you! It finally worked. I tried to update vctrs through updates under packages earlier but that didn't work. Now it finally did. Thank you a lot!!

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.