Installing and Using Python Packages using Reticulate

First I install miniconda...


Then Check to see if Pandas and bcpandas are installed...

> py_module_available("pandas")
> py_module_available("bcpandas")

ok so next step is to install them!

py_install(envname = "C:\\Users\\xxxxxx\\AppData\\Local\\r-miniconda\\envs\\r-reticulate", packages="pandas")
py_install(envname = "C:\\Users\\xxxxxx\\AppData\\Local\\r-miniconda\\envs\\r-reticulate", packages="bcpandas")

Then Check to see if Pandas and bcpandas are installed...

> py_module_available("pandas")
[1] TRUE
> py_module_available("bcpandas")

Only pandas is available. Why ?!

Some points...

1.) I think py_config shows I'm in the correct folder

> py_config()
python:         C:/Users/xxxxxx/AppData/Local/r-miniconda/envs/r-reticulate/python.exe
libpython:      C:/Users/xxxxxx/AppData/Local/r-miniconda/envs/r-reticulate/python36.dll
pythonhome:     C:/Users/xxxxxx/AppData/Local/r-miniconda/envs/r-reticulate
version:        3.6.11 (default, Aug  5 2020, 19:41:03) [MSC v.1916 64 bit (AMD64)]
Architecture:   64bit
numpy:          C:/Users/xxxxxx/AppData/Local/r-miniconda/envs/r-reticulate/Lib/site-packages/numpy
numpy_version:  1.19.4

2.) I can see that the package bcpandas is available in the folder in question... C:/Users/xxxxxx/AppData/Local/r-miniconda/envs/r-reticulate/Lib/site-packages/

3.) Ive tried various combinations of uninstalling & reinstalling RStudio, Miniconda, Tried the Devtools version of reticulate, tried creating a new conda folder using condainstall instead of py_install... Whatever I do I cannot seem to be able to access bcpandas using reticulate.

This has been really driving me totally mad today... Please help for the sake of my sanity!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.