Installation problem of gMatrix

I want to install gMatrix package.
I would be grateful if someone could help me.

Warning message:
package ‘gMatrix’ is not available (for R version 3.6.3)

That package is no longer on CRAN, you can try to install it from GitHub, follow instructions on the GitHub repo.

I tried and followed above link But I am getting this error.

(base) shazia@shazia-Lin:~$ R CMD INSTALL gmatrix

  • installing to library ‘/home/shazia/R/x86_64-pc-linux-gnu-library/3.6’
  • installing source package ‘gmatrix’ ...
    ** using staged installation
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    setting CUDA home directory to ..
    checking for ../bin/nvcc... no
    configure: error: nvcc not found!
    ERROR: configuration failed for package ‘gmatrix’
  • removing ‘/home/shazia/R/x86_64-pc-linux-gnu-library/3.6/gmatrix’
    (base) shazia@shazia-Lin:~$

You are missing a system dependency, on what operating system are you?


Actually I want to install qqman and gMatrix package.

qqman package dependency is >=R 3.5 and gMatrix package dependency is below 3.5 R version...

If I install R 3.4 version then I am able to install gMatrix package but not qqman package..
and if I install R 3.6 version then I am able to install qqman packages but not gMatrix package....

I want to install both packages ....

if possible please tell me the solution.


I am on Ubuntu 18.04.

You are missing the CUDA drivers, this is not an R package dependency, this is a system dependency. Here is a guide I found to install the Nvidia CUDA drivers on Ubuntu 18

How to install system dependencies....

package ‘gmatrix’ is not available (for R version 3.6.3)

I already gave you a link to a guide on how to install the driver, try to follow it. This is not R related so being more detailed than that would be off-topic.


I tried above link.. Is it installed?
(base) shazia@shazia-Lin:~$ nvcc --version
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2017 NVIDIA Corporation
Built on Fri_Nov__3_21:07:56_CDT_2017
Cuda compilation tools, release 9.1, V9.1.85

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.