Install_tinytex() thru a ntlm auth proxy

Recently, some TI guy change something somewhere in the multiple content filtering software in the proxy on my job, and now i can't install tinytex.

The error i got is

Error in curlGetHeaders("") : 
  libcurl error code 28:
 	Failed to connect to port 443 after 21001 ms: Timed out

I am sure that the problem is related to the enterprise proxy settings. The url mirror.ctan is accessible thru Chrome, so TI don't know what to do to unblock the url without allowing a DIRECT access to it.

What i know, i have to set proxy and proxy auth for curl to get it to download something. For example, in my last tinytex install, i created a .curlrc file in the curl folder to get it to install packages, which said

--proxy-user doesntmatter:whatiput

(i haven't tested if i really need to set proxy-user, but it worked with whatever i put in it)
i can set the proxy with

Sys.setenv("https_proxy" = curl::ie_get_proxy_for_url(""))

But then i got a http 407 error. How can i set the auth type to proxy-ntlm?

(Yesterday i got a similar problem with the cran repositories, in a R 4.2.1 install; install.packages() didn't work, but it worked in a R 4.1.3 install in the same computer. Rather than mess with proxy settings, i set the default repository to to get install.packages() working again. Maybe they enabled some kind of special filtering for curl, based on curl's user-agent?)

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.