Install packages loading forever

Hi, I am running code on RStudio, and cannot get past the install.packages("caret") section of the code, it's been loading for a day. I downloaded the newest version of R, and it has been no avail. Could it be not connecting correctly, or is there another reason this library won't load?

Your experience strongly suggests network congestion between your connection and the repository. In the top menu choose Tools | Global Options | Packages | Management | Primary CRAN repository | Change (10-15 seconds for the list to come up) and pick a mirror that's geographically closer.

The caret package is less than 5.0 MB. Anything longer than a minute shouldn't be happening even if minor network congestion is occurring.

I tried changing the CRAN repository from the Global (CDN) - RStudio connection, to the one nearest to me, and the line install.packages("caret") still remains loading. Could anything else be causing this?

Is your internet connection behind a proxy server or firewall? This is usually the case when you are at work or school

Nope, I am on my home internet. The package installation has worked in the past; it began asking me continually to restart RStudio as it said my version was out of date, and now that I downloaded the new version of R - 3.5, it only loads without running. Other libraries such as ggplot2 and gridExtra will load, but not the caret library or its package installation. Any help is greatly appreciated-

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.