install packages error

Find help! Thanks in advance! When I install tidyverse packages, it shows these results, I already tried exit and start again, but it didn't help.

Error: package or namespace load failed for ‘tidyverse’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
there is no package called ‘stringi’

Error in download.file(url, destfile, method, mode = "wb", ...) :
download from '' failed
Warning in install.packages :
download of package ‘stringi’ failed

Many thanks!

the code I use:


Can you post the complete error message you get when you run this command?


My suggest would be: Restart RStudio then go to Tools, then Install Packages, type tidyverse, make sure the box "Install dependencies" is checked. If R asks to compile package from source, select No.

thanks for your help! I will try it later!

my result show the same problem, I have already open a new topic, many thanks!

This seems like a connectivity issue, do you have connectivity restrictions of some kind ike a firewall or proxy server (common when you are at school or work)? or is your internet connection unstable?

Note: I have moved your posts here because you were hijacking another person's topic.

Many thanks! Because I just used it, I thought the last reply I already added in my topic! Thanks for your help! I solved the problem!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.