install fastcmprsk package

I need to use the package fastcmprsk to run a prediction model. However, this package is removed from the CRAN repository in the current R version. I tried to use the following codes to install it:
remotes::install_version("fastcmprsk", version="1.1.1")
It failed with the following error message (I typed the error message since I can't copy and past it from R to this page. It may contain typos):
Downloading package from url:

Installing 1 packages: dynpred

trying URL ''

Content type 'application/x-gzip' length 107788 bytes (105 KB)

downloaded 105 KB
installing source package 'dynpred' ...
package 'dynpred' successfully unpacked and MD5 sums checked
using staged installation
Error n system(paste(MAKE, p1(paste("-f",shQuote(makefiles))),"compilers"), :slight_smile: 'make' not found
*removing 'C:/Program Files/R/R-4.3.1/library/dynpred'

The downloaded source packages are in 'C:\Users\xxx\AppData\Local\Temp\RtmpILXcj9\downloaded_packages'
ERROR: dependency 'dynpred' is not available for package 'fastcmprsk'
*removing 'C:/Program Files/R/R-4.3.1/library/fastcmprsk'
Warning messages:

  1. In missing_devel_warning(pkgdir):
    Package fascmprsk has compiled code, but no suitable compiler(s) were found. Installation will likely fail.
    Install Rtools (Removed the link). Then use the pkgbuild package or make sure the Rtools in the PATH.
  2. In i.p(...): installation of package 'dynpred' had non-zero exit status
    3: In i.p(...):
    installation of package (removed the link)had non-zero exit status

Have you installed RTools?

why not? Retyping all that with so few typos was a heroic effort, thank you :slight_smile:

I install Rtools43 installer on my computer: Rtools43 for Windows

Thanks for your response. I installed Rtools43 for Windows. After I download it to my computer, I restart the computer. Then, I use the codes to install fastcmprsk package. It works this time.

Problem solved. Thanks a lot!

1 Like

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.