install BiocManager

I try to Install BiocManager, and I keep getting that message : Warning messages:
1: In list.files(cacheDir) :
unable to translate 'C:/Users/<U+05DE><U+05D0><U+05D9><U+05D4> <U+05D5><U+05D9><U+05E0><U+05E8>/AppData/Local/RStudio/explorer-cache' to native encoding
2: In normalizePath(path.expand(path), winslash, mustWork) :
path[1]="C:/Users/???? ????/Documents": The filename, directory name, or volume label syntax is incorrect

I know that I have problem becouse of :"C:/Users/???? ????/Documents".
I try to run RStudio as "administrator" and it didnt work.

What can I do to fix it ?

It seems like you have non ASCII characters in your Windows home folder, R has problems with that very often, I would recommend setting your package library in a different location.

You can change the default library folder by setting your R_LIBS_SITE environmental variable in a .Reviron or .Rprofile file. For example:

# In a .Renviron file you can set it by adding a line like this one with the desired location 
R_LIBS_SITE="C:\\Program Files\\R\\R-4.1.2\\library"

For a more detailed explanation, you can read this blog post

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.