Incompatibilities with Python Installation and OpenSSL

I've configured RStudio Server, multiple R installations and Python 3 according to the best practices listed in the documentation. One issue I'm running into is I believe incompatibilities with OpenSSL are causing issues with things like scp and Git via ssh.

When I open a new session my LD_LIBRARY_PATH looks like this:


If I open a .py file, and execute it via Reticulate it executes fine but opening a new Terminal window my LD_LIBRARY_PATH looks like this:


When attempting to scp or Git clone with ssh I see errors like:

/usr/bin/ssh: symbol lookup error: /lib64/ undefined symbol: EVP_KDF_ctrl, version OPENSSL_1_1_1b
lost connection

Thoughts or advice on better ways to support this?


1 Like

Which OS are you using? What is the output of ldd /usr/bin/ssh in the two terminals?

1 Like

CentOS Linux release 8.3.2011


$ ldd /usr/bin/ssh (0x00007ffea8da6000) => /lib64/ (0x00007fc1e5d70000) => /lib64/ (0x00007fc1e5b6c000) => /lib64/ (0x00007fc1e5968000) => /lib64/ (0x00007fc1e5751000) => /lib64/ (0x00007fc1e5528000) => /lib64/ (0x00007fc1e5311000) => /lib64/ (0x00007fc1e50e7000) => /lib64/ (0x00007fc1e4e92000) => /lib64/ (0x00007fc1e4ba9000) => /lib64/ (0x00007fc1e4992000) => /lib64/ (0x00007fc1e478e000) => /lib64/ (0x00007fc1e43cb000) => /lib64/ (0x00007fc1e41ab000)
        /lib64/ (0x00007fc1e6513000) => /lib64/ (0x00007fc1e3f27000) => /lib64/ (0x00007fc1e3d16000) => /lib64/ (0x00007fc1e3b12000)


$ ldd /usr/bin/ssh (0x00007ffe6f4c9000) => /opt/Python/3.9.1/lib/ (0x00007f973fe76000) => /lib64/ (0x00007f973fc72000) => /lib64/ (0x00007f973fa6e000) => /opt/Python/3.9.1/lib/ (0x00007f97405fd000) => /lib64/ (0x00007f973f845000) => /lib64/ (0x00007f973f62e000) => /lib64/ (0x00007f973f404000) => /lib64/ (0x00007f973f1af000) => /lib64/ (0x00007f973eec6000) => /lib64/ (0x00007f973ecaf000) => /lib64/ (0x00007f973eaab000) => /lib64/ (0x00007f973e6e8000) => /lib64/ (0x00007f973e4c8000)
        /lib64/ (0x00007f97403ff000) => /lib64/ (0x00007f973e244000) => /lib64/ (0x00007f973e033000) => /lib64/ (0x00007f973de2f000)

I believe the issue is the change to => /opt/Python/3.9.1 but unsure of how to address this without potentially breaking other functionality.

Indeed, it looks like the binary python installation comes with its own version of OpenSSL that is incompatible with the system version, even though both are version 1.1. Maybe they have been compiled with slightly different options.

Can you try installing Python from source as a workaround? RStudio Install Python From Source - RStudio Documentation

I can give that a try. Think that would solve it?

These are the steps I used, with miniconda - Integrating RStudio Server Pro with Python - RStudio Documentation

Any downside as far as RStudio integration/support?

Installing from source seemed to work just fine. I'll have to do some more testing and have some end users try it out but seems to be a workable solution. Anaconda environments would be more flexible will give this a shot. Thank you, @rstub!

Great to hear that! When compiling from source you will use things like OpenSSL from the system, keeping it consistent with other tools. Unfortunately python from miniconda includes some of these libraries, resulting in the incompatibilities you have encounterted.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.