I tried to view a json file in RStudio and now RStudio is broken

Yesterday I already had RStudio open and then I tried to open a large json file, just to see it for a second. RStudio crashed with the message below. Now whenever I try to open RStudio, I get the same message. I deleted the json file. I restarted my computer. I uninstalled and reinstalled RStudio. I still get the same message.

This https://support.rstudio.com/hc/en-us/articles/200534577-Resetting-RStudio-Desktop-s-State is probably worth a try and may do the trick. There is probably something left over in the desktop state for RStudio that is making try finish opening that json file.

Thanks for the great information! I thought all RStudio stuff had been removed when I uninstalled.

@Ranae: Any chance you can share the JSON file you had attempted to open in the RStudio IDE? We'd love to try and reproduce the issue locally so that we might be able to ensure that you (or other users) don't bump into this in the future!

Thanks, Kevin!

You should be able to get the file at this link.

I'm using Windows 10 and I had a python script running (downloading data) in the terminal in RStudio when the crash first occurred. I had just updated R and RStudio in January.

1 Like

Awesome! Thank you @Ranae -- I've reproduced the issue locally, and we'll see if we can figure out what's going on.