I now know what it means to be completely stumped

I teach quantitative genetics and biometrics at the Department of Plant Breeding and Genetics, Federal University of Agricultural Makurdi, Benue-Nigeria. I used to believe I could never be completely stumped on an issue. I was dead wrong. I now know what it means to be completely stumped. I mean to be way deep in above your head.
I have been learning how to use R studio for analysis. Having learnt the basics, it got to downloading packages so I could have a proper hands on by doing some statistical analysis. I have not been able to download any package no matter how and what I have tried. My wont just connect to the repository.
Below is the warning messages I keep getting;

Warning: unable to access index for repository http://cran.rstudio.com/src/contrib:
cannot open URL 'http://cran.rstudio.com/src/contrib/PACKAGES'

Based on suggestions, these are the things I have tried

-I changed mirrors. Since I am Nigeria, I tried the one in South Africa and the Algeria with out success. I then read online that one can choose any CRAN mirror any where around the would and it wont matter. So I tried USA, Canada, France, UK. It did not change the outcome.

-I went to Tools >Global options >Packages >unchecked the box for "Use secure download method for HTTP" . It still did not change the outcome.

I'd love to hear from us on how to solve this issue and get cracking with my analysis.
Thank you

I am no expert in this type of problem but can I suggest a couple of approaches that have helped me.

install.packages("readODS", dependencies=TRUE, repos='http://cran.rstudio.com/')

substituting your package name for readODS and, perhaps, changing the repository.

Alternatively try bypassing RStudio and try a download using the R Gui or opening a terminal and loading R there. This won't solve the RStudio problem but may get the packages.

A final suggestion is investing in a high quality crash helmet to reduce injuries as you pound your head against the wall or on the desk. R is fantastic but it can be a bit frustrating at times.

Disregacd that first suggetion as I suddenly went "Duh, they have already done that!"

1 Like

If you open a normal browser window and enter the URL
what happens? If you get an error, you may have a permission problem getting from your network to the repositories.

1 Like

Thank you for this suggestion. So I tried it as you suggested and there was no block at all. i accessed the repository. so it seems its something else.

Any luck installing directly to R ?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.