I need help with packages installation

When packages are not in the right version, how do I install the right versions, especially when I have a version that is not working with my R version, how do I resolve this?

I have this issue with the package 'anacapa', I think I need cli package to install it but I am having the wrong version. I have this message on the console:

Error in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]) :
namespace ‘cli’ 3.0.1 is already loaded, but >= 3.1.0 is required
It also says the package 'anacapa' is not available for this R version (I use R version 4.1.0).
How do I resolve this?
I believe I may still meet this issue going forward, I need help.

This particular excerpt of the error message is asking you to update the cli package, to solve this part you simply have to run


However, that is not the cause of your inability to install anacapa or maybe ranacapa since you have also wrote it that way.

You are simply not passing the GitHub repository argument correctly, for example, if I assume you actually want to install gauravsk/ranacapa package, the correct command would be.


Have in mind that this package has non-CRAN dependencies that you need to install from Bioconductor as stated on the installation instructions

This works, thanks.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.