I don't get the opition “Website using blogdown” in “Project type” after installing the blogdown package

I'm trying to create a Hugo website using blogdown using RStudio but I don't get the option "Website using blogdown", does someone know how to fix this?

On my Windows computer I have installed and activated the blogdown package, but when I want to create a new project (File -> New project -> ) there is no option type: "Website using blogdown". I have also installed Hugo by using the command blogdown::install_hugo()

The options available after File -> New project -> New Directory are New project , R Package , Shiny Web

All packages are updated.

I'm using a Widows computer and Rstudio Version 1.2.5001

Hi there,

Just to eliminate one of the simpler solutions, have you restarted RStudio and your R session? When you click on the "Addins" dropdown in your RStudio IDE, are you seeing the blogdown package addins like "Serve site"?


1 Like

Thanks @apreshill :slight_smile: Unfortunately not. There is nothing in the "Addins" dropdown. When I look at the "Addins" dropdown it says "NO ADDINS FOUND"?

I think that there might be something wrong with my RStudio IDE, so I tried to uninstall and then reinstall, but I probably failed to do that properly. This is how I did: first uninstalled RStudio and R from using the control panel (Control panel -> uinstall). Then I also followed the instructions on (https://support.rstudio.com/hc/en-us/articles/200534577-Resetting-RStudio-Desktop-s-State) to hide the settings. Somehow, when I reinstalled R and RStudio it seems like the old settings are still there because I got the same problem as before and all packages that I had previously where there. How do I get a new, clean slate installation of RStudio?

Packages are not related to your RStudio installation but to your R installation and to your library folder.

@andresrcs thanks! (I should have figured out that myself :slight_smile: )

It sounds like there are other issues going on with your setup. But you can be sure that if you have restarted R and RStudio and you are not seeing the blogdown package addins that you do not have the blogdown package installed. If you run library(blogdown) in your R console I suspect that it will not be found. The blogdown package needs to be installed to see the website option in the RStudio project wizard.

1 Like

Tanks @apreshill i agree there is something very strange about my RStudio stetup! I can confirm that blogdown is installed, or at least I can see it in the Package -> User library and when I run library(blogdown) there is nothing "Addins". What do you recommend: try to find and fix what's wrong or to start from scratch again? I've tried to start from scratch, but so far it's been unsuccessfull. Whenever I've tried to uninstall both R and RStudio, the same problem has reappeared. By the way, I really appreciate your help :slight_smile:

@apreshill do you have any suggestions on how to fix the problem?

Hi- no I'm sorry- if you are not seeing the add-in then I do not believe you have installed the blogdown package. Once you are able to sort out your install issues, and restart RStudio, it should be there. It is tough to tell whether your issue here is more general with RStudio and your R installation (perhaps check out https://rstats.wtf/ if so) or if you are actually seeing a blogdown issue.

Thanks @apreshill then next step for me is to focus on problem solving installation issues. Good, then I know where to start.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.