I can't Open My RStudio

Error Information:

Description of issue
It's been a while I am not using my R Studio application
I download the latest version of R Studio and when I try to open it
It just show a blank window briefly and I got an error message that said RStudio quit unexpectedly

with this problem details:

Process: RStudio [879]
Path: /Applications/RStudio.app/Contents/MacOS/RStudio
Identifier: org.rstudio.RStudio
Version: 1.3.1093 (1.3.1093)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: RStudio [879]
User ID: 501

Date/Time: 2021-12-01 08:55:50.673 +0700
OS Version: Mac OS X 10.15.7 (19H1519)
Report Version: 12
Anonymous UUID: C5497790-A044-0A94-1C15-77C8E66AD4C5

Time Awake Since Boot: 460 seconds

System Integrity Protection: enabled

Crashed Thread: 22 Chrome_InProcGpuThread

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
abort() called
Application Specific Signatures:
Graphics kernel error: 0xfffffffb

Attempted steps taken to fix
I try to reinstall both R and RStudio application and restart my MacBook but it didn't work

System Information:

  • RStudio Edition: (Desktop)
  • RStudio Version: 2021.09.1+372
  • OS Version: Catlina 10.15.7
  • R Version:R 4.1.2 GUI 1.77 High Sierra build (8007)

You might be experiencing this issue: RStudio quits unexpectedly at startup on macOS · Issue #10020 · rstudio/rstudio · GitHub - does the workaround listed there help?

I have tried some of the suggestions in that thread; however, my R Studio still doesn't want to start.

I wrote in the terminal this code as suggested, but it just doesn't work.
Last login: Thu Dec 2 19:30:49 on ttys000
[192:~] dinafauziah% defaults write com.rstudio.desktop $'desktop\xb7renderingEngine' 'software'
Illegal variable name.

Even when I tried to open the R-Studio through the Terminal, It just failed to open and showed the same error notification
[192:~] dinafauziah% # macOS
#: Command not found.
export RSTUDIO_CHROMIUM_ARGUMENTS="--disable-gpu"
[192:~] dinafauziah% export RSTUDIO_CHROMIUM_ARGUMENTS="--disable-gpu"
export: Command not found.
[192:~] dinafauziah% /Applications/RStudio.app/Contents/MacOS/RStudio
[192:~] dinafauziah%

Any other suggestions?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.