I can't install packages with Rstudio

I am completely new to Rstudio and I simply can't install any additional packages. I've attached the description of the error below:

Can someone help me?

Have you tried saving and install after?
I had this issue and either saving or closing and reopening rstudio worked for me

R has problems with cloud-synced folders (OneDrive in your case), I recommend you to set your package library in a non-synced folder.

You can change the default library folder by setting your R_LIBS_SITE environmental variable in a .Reviron or .Rprofile file. For example:

# In a .Renviron file you can set it by adding a line like this one with the desired location 
R_LIBS_SITE="C:\\Program Files\\R\\R-4.1.2\\library"

For a more detailed explanation, you can read this blog post

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.