I am not able to be getting start with RStudio with Ubuntu in a windows subsystem (Windows main, Linux)

Error Information:

Description of issue - I have already installed RStudio in my windows. I need Linux for running some code in RStudio. I installed the Linux (Ubuntu) subsystem from the Microsoft Windows official site and installed it in the same system. I installed RStudio in Linux with all necessary packages. I can open the R script in the terminal, but I can not lunch the RStudio app. It is showing on my startup that I have two RStudio when the windows versions is launching. Any suggestions will be highly appreciated! Thank you so much!

Attempted steps taken to fix - Reinstalled RStudio. Changed internet connection. Reinstalled R packages. downloaded an older version of RStudio (RStudio 4.1.1)

System Information:

  • RStudio Edition: Desktop
  • RStudio Version: 4.1.1
  • OS Version: Windows 11 Pro 64-bit Version: 22000.856
  • R Version: 4.2.1
  • Output your diagnostics report (if possible):

From RStudio Desktop Will Not Start on support.rstudio.com

On WSL is easier to use RStudio Server, then you can access an RStudio session from a browser.

Thank you so much for the information. Can you please guide how I can use it through server? I never used like that way!

Take a look at this support article

Thank you so much for finding this resource. I appreciated it!

The server was showing error in installing couple of packages like raster, tidyverse, RStoolbox. I managed to install tidyverse and raster package, but couldn't install RStoolbox. Error messages are:

ERROR: lazy loading failed for package ‘exactextractr’

  • removing ‘/home/jannatul/R/x86_64-pc-linux-gnu-library/4.2/exactextractr’
    Warning in install.packages :
    installation of package ‘exactextractr’ had non-zero exit status
    ERROR: dependencies ‘rgdal’, ‘exactextractr’ are not available for package ‘RStoolbox’
  • removing ‘/home/jannatul/R/x86_64-pc-linux-gnu-library/4.2/RStoolbox’
    Warning in install.packages :
    installation of package ‘RStoolbox’ had non-zero exit status

The downloaded source packages are in

When I tried to install dependencies, it showed error:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libgdal1-dev

Does anyone has any solution for this? Please help! Thank you so much.

This is a different question not related to the IDE but to the installation of an R package. We like to keep things tidy around here so next time please ask it on a new topic.

In short you are missing a system dependency that you have to install

sudo apt -y install libgdal-dev

Thank you. I tried this, it is still showing same error. I have created a new poll for this problem now.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.