How to update RStudio on AWS EC2 instance (Ubuntu)?

What I've done:

  1. Downloaded rstudio-1.2.1047-amd64.deb (preview version)
  2. Ran sudo dpkg -i rstudio-1.2.1047-amd64.deb

When I open RStudio ( I still get the old version (according to About RStudio).

I tried restarting the instance, but that didn't help.

What am I missing?

I'm fairly certain you need to install RStudio Server to access it remotely, not the regular RStudio. So, name of the file you are installing should be rstudio-server-1.2.1047-amd64.deb.

What version of RStudio do you see when you click on About RStudio?

1 Like

I agree with @mishabalyasin. It looks like you are installing R Studio Desktop then starting R Studio Server. So you're seeing the R Studio Server version when you open R Studio Server. Here's the install instructions for R Studio Server on Ubuntu:

Ah, I see, thanks!

I only see rstudio-server-1.1.456-amd64 available. Trying to download rstudio-server-1.2.1047-amd64.deb gives 404 error.

Do you happen to have a link to the latest version?

All preview versions are at a different page -

1 Like