How to link installed Python packages to RStudio?

Hello all,

I'm using Python inside RStudio with reticulate package. My Python packages such as Pandas, Numpy, and requests are already installed on my computer. But RStudio can't find it.

Here's the Python location inside RStudio:

> library(reticulate)
> py_config()
python:         /Users/Mike/Library/r-miniconda/envs/r-reticulate/bin/python
libpython:      /Users/Mike/Library/r-miniconda/envs/r-reticulate/lib/libpython3.6m.dylib
pythonhome:     /Users/Mike/Library/r-miniconda/envs/r-reticulate:/Users/Mike/Library/r-miniconda/envs/r-reticulate
version:        3.6.12 | packaged by conda-forge | (default, Dec  9 2020, 00:24:39)  [GCC Clang 11.0.0]
numpy:          /Users/Mike/Library/r-miniconda/envs/r-reticulate/lib/python3.6/site-packages/numpy
numpy_version:  1.19.5

NOTE: Python version was forced by use_python function

Here's the location of my Python:


I have tried to set path:


But, it doesn't work. I don't want to install Python packages to Rstudio again. I'm aware I can use:


How you connect your Python packages to RStudio? Thanks a lot!

I'm OP. I just found this on the RStudio website. It's very useful, but still haven't found the solution to my problem.

In fact, this page provides some more details, but still doesn't answer my question.

Have you tried to set python interpreter from the settings? It works for me.

Wow, I think that was it! I just tried to load a few packages. It seems to work without any errors.

Thanks @Yarnabrina , I will report back if I do run into errors.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.