How to install extracat?

There is a example for categorical data visualization from the following link:

packages "extracat" was required, author described the installation as:
"3 . In the terminal type the following command to install the extracat package: ` R CMD INSTALL -1 C:/Users/User/Desktop/Fluctuation extracat_1.7-6.tar "

But following the instruction, kept receiving error message, is there other way to install this package? Thank you!

What is the exact error message you are getting? Have in mind that the author is asking you to install an archived package with might not be even possible with the latest R versions.

You might need to downgrade R to the version the author was using at the time of writing.

I typed "R CMD INSTALL -1 C:/Users/****/Downloads/extracat_1.7-6.tar
Attached snapshot is the message I got:

I just tried it out and it installs just fine, you just have to install a couple more dependencies

install.packages(c("hexbin", "reshape2"))

And then you can run the command install from the terminal if you want but without the -l option

R CMD INSTALL C:/Users/****/Downloads/extracat_1.7-6.tar

Thank you!
I installed "hexbin", "reshape2" and tried again, but got another error message "make not found", please see the attached screenshot.

Have you installed RTools, you need it to compile packages from source. You can download it from here.

Yes, it was installed before. Thank you.

Well, apparently you haven't install it correctly, or you don't have a suitable version since R can't find the make command. I recommend you to double check on that.

I just re-intalled RTool and tried again, still got error message no "make".

What version of R and RTools are you installing? Are you changing the default options while installing RTools?

R is 4.1.2
RTool: rtools42-5355-5357

That version of RTools is for R >= 4.2, for your R version you need to install (and configure) RTools 4.0, although, it would be easier if you update your R version since it requires no manual configuration.

If you do update, have in mind that on Windows each R version gets its own package library so you would need to install package dependencies again for the new version.

Reintalled RTools40, but doesn't work. Thank you.

As I said, Rtools40 requieres manual configuration to work, have you added RTools40 to the PATH as instructed in the installation instructions?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.