How to I update rstudio on Red Hat Linux?

I did some Google searching on how to do this and found it hard to get a clear answer. In help > rstudio I can see that I am on version 1.2.1335.

On a separate issue I was having I found some online suggestions telling me to use a more recent rstudio version.

I'm running hosted rstudio community edition on a Linux server, Red Hat. In the help menu, there is no update option. Sounds like there are in some cases, perhaps on different platforms, but not on my instance:
Screen Shot 2020-04-17 at 11.37.37 AM

I did a search on this site but was unable to find anything, perhaps I'm using the wrong search term: Search results for 'update rstudio linux' - Posit Community

I also did some Google searching but the results were crowded out either with instructions on how to update packages else instructions on how to update rstudio using the help menu.

How should I update rstudio to the latest version?

Just download and install the appropriate installer for your Red Hat version

Hi, I tried that just now with:

sudo yum install -y


After that, is there anything else I need to do? It seems I'm still on the same rstudio version, 1.2.1335.

Am I missing something here? How can I get the latest version? Or have I missed some steps?

I also tried sudo rstudio-server restart after installing the rpm, still no change, I'm on version 1.2.1335

Sorry I didn't notice you were talking about a server, in that case, you need to install the server version, look for installation instructions here

Oh boy! I did that and now rstudio will not load. I don't see the login screen. Tried sudo rstudio-server start /usr/lib/rstudio-server/bin/rserver: error while loading shared libraries: cannot open shared object file: No such file or directory

What should I do :confused:

I installed the wrong version! D'oh.
It's back up now with:

sudo yum install -y

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.