How to fix rstudio scrollbars which appear very wide


the scrollbars in rstudio Version 1.2.1335 under Ubuntu 18.04 are very wide on my machine. When I inspect them they are 35 pixels wide which looks odd and clunky.

I think this has happened recently but can't find anything which would indicate how to fix it.

Screenshot attached.

Are you working with RStudio on a high DPI display, or something similar? Have you set up any custom UI scaling on your machine?

I'm on a monitor with 1920 x 1080 resolution.

I don't think I have anything odd set regarding scaling.

gnome-tweak tells me that my scaling factor is 1.00.

gsettings get org.gnome.desktop.interface text-scaling-factor

tells me it's set at 1.0

And as far as I recall I haven't set anything else.

Interesting! Do you have the IDE zoomed in, or anything like that? I'm surprised since to the best of my knowledge we've only observed this issue when using high DPI displays.

One other thing worth checking: does it make a difference if you force software rendering, as opposed to using the GPU?

Thanks Kevin.

Weird thing - just fired up Rstudio to check and the scroll bars are normal now.

All that's happened in the last few days is that I've installed the usual Ubuntu 18.04 updates and rebooted the machine. Not changed anything else.

Just tried changing the gnome tweak settings, suspending the laptop, plugging it into an external monitor etc - it still stays normal.

For info the rendering engine was on auto-detect.

So oddly this problem seems to have disappeared. I'll keep an eye on it and get back to this if it reappears.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

I've now solved this problem.

It turns out that Ubuntu was mis-reading my monitor model over the HDMI port (after a suspend). It correctly reported the 1920 resolution but thought it was a 7" monitor (instead of a 24" monitor). That meant the dpi was wrong and interface elements such as the scroll bar went AWOL. :wink:

It is documented here:

I fixed it by using a VGA/VGA cable from the laptop to my docking station instead of the HDMI/HDMI cable. Ubuntu now sees a 24" Samsung monitor and Rstudio runs fine on the native laptop screen and on the external monitor.

The fundamental issue was therefore Ubuntu changing the dpi based on the monitor it thought I was using.


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.