How do i install the SeuratObject package?

Welcome to the forum.

Presumably by


Yes, that would be ideal. I keep getting an error and a 'BLOCK':
installing to /cloud/lib/x86_64-pc-linux-gnu-library/4.0/00LOCK-SeuratObject/00new/SeuratObject/libs
** R
Error in parse(outFile) :
/tmp/RtmplI6TAn/remotes2ef8784992ba/SeuratObject/R/assay5.R:174:13: unexpected input
173: expr = Layers(object = object, search = layer),
174: error =
ERROR: unable to collate and parse R files for package ‘SeuratObject’

  • removing ‘/cloud/lib/x86_64-pc-linux-gnu-library/4.0/SeuratObject’
    Warning message:
    In i.p(...) :
    installation of package ‘/tmp/RtmplI6TAn/remotes2ef8784992ba/SeuratObject’ had non-zero exit status

! keep getting an error and a 'BLOCK':
installing to /cloud/lib/x86_64-pc-linux-gnu-library/4.0/00LOCK-SeuratObject/00new/SeuratObject/libs

Clearly something went wrong on an earlier attempt. You need to hunt down and get rid of that OOLOCK file or folder before you can do anything else.

Kill it and try again. If you get the same error we likely will need a lot more information

can you give us the output of


to start with?

How do i go about finding that file? I've done that before on a desktop version, but i haven't managed to find it in the cloud environment. Here's the sessionInfo:
R version 4.0.5 (2021-03-31)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 20.04.6 LTS

Matrix products: default
BLAS: /usr/lib/x86_64-linux-gnu/atlas/
LAPACK: /usr/lib/x86_64-linux-gnu/atlas/


attached base packages:
[1] stats graphics grDevices utils datasets methods base

other attached packages:
[1] RcppEigen_0.

loaded via a namespace (and not attached):
[1] compiler_4.0.5 bookdown_0.21 cli_3.6.2 htmltools_0.5.1 tools_4.0.5 rstudioapi_0.16.0 yaml_2.2.1 remotes_2.5.0 Rcpp_1.0.12
[10] rmarkdown_2.6 blogdown_1.0 knitr_1.30 xfun_0.20 digest_0.6.35 rlang_1.1.3 evaluate_0.14

The 00LOCK file should be located in the folder where R installs packages on your system. Running .libPaths() should tell you where that folder is located. I've never used it, but install.packages also has an INSTALL_opts argument where you can set --no-lock to prevent a lock file from being created. For example:

install.packages("SeuratObject", INSTALL_opts = '--no-lock')

Well, i've navigated to the library, but there's no BLOCK file/folder. And, i've tried installed with the no-lock option. I did, however, find this...apparently some issues with shorthands:

"there's no BLOCK file/folder"

It is a 00BLOCK file not a BLOCK file/folder. In Ubuntu, it will be the first file/folder in the preceding folder.

Ouch, I just realized you are installing in the Cloud. I don't know how this affects things. On a local installation just doing a search for 00LOCK-SeuratObject should give you a path to it. the cloud. I've dealt with those lock files on a desktop before. Just can't seem to find the file on the Cloud

I've never used the Cloud so I am of no use. Good luck.

You marked this topic as solved, did you manage to solve?

If not, what kind of Cloud are you using, any way to get a more recent version of R? From your Github link that would solve it, and R 4.0.5 is pretty old by now.

I'm using the default R installation provided by Posit. I found this thread that helped me get around the issue: