High Sierra Memory Leak Issue?

Apologies for cross posting and tweeting...

  • RStudio Server Preview (RStudio Server 1.1.375 - Ubuntu 12.04+/Debian 8 (64-bit))
  • R (3.4.1)
  • Ubuntu 16.04.3 LTS (GNU/Linux 4.4.0-93-generic x86_64)
  • Proxy forwarding
  • Tried on:
    • Firefox (55.0.3 (64-bit))
    • Chrome (Version 61.0.3163.100 (Official Build) (64-bit))

This has worked fine for ~2 years, but since upgrading to MacOS High Sierra I've found no way around this issue.

When opening Firefox (Proxy set at SOCKS v5) and pointing to localhost:8787, the session begins but then hangs. Around 7-8 seconds after the session starts, a yellow popup bar opens saying that "this page is slowing down your browser - Stop it or wait?". Stopping makes the script code box editable, however non of the buttons work, or anything else for that matter. Waiting results in the resource usage goes crazy (>32GB in a minute, 100%CPU usage).

Chrome just crashes out.

I'm a bit stumped and hoping someone at RStudio can help me narrow down what's causing this... I'm happy to test any ideas and report back because right now my session is unusable.

I've tried the usual remedies of a reboot, making sure everything is up to date, etc.



Major Release v1.0.153 seems to be working fine, as such I think this is a bug isolated to v1.1.375

This sounds like a bug in the RStudio user interface. I'd start by logging out in your browser, shutting down RStudio Server (via rstudio-server stop), renaming your ~/.rstudio directory to ~/.rstudio-old, and then starting the server again (via rstudio-server start).

Does that make the problem go away?