Hidden dataframes in the global environment [Partially Solved]


I realized that created data frames in the global environment started with "t" went invisible (or it was like that for a while now). Moreover, when I create a new data frame that begins with "t" or with the other letters come after "t" alphabetically, don't appear in the global environment, even though they can be called from console.

I have also listed the data frames in the global environment ( ls()[sapply(ls(), function(x) class(get(x))) == 'data.frame'] ) and all of the data frames begins with "t" (and begins with the other letter which comes after "t") were in the list.

I have no idea what can cause this. I restarted everything multiple times but my problem wasn't solved at all. Since I am doing version control between the datasets, it is important for me to see them physically in the environment.

I am using R 3.6, RStudio Version 1.2.1335 on Ubuntu 16.04 (LTS).

Edit: I realized that the environment pane is showing only a limited number of data frames under the data category. So is there a way to make all of the data frames created visible in the environment pane?

Any suggestion is appreciated!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.