Help with RcmdrPlugin.NMBU

Dear community,
I am running the latest R Stats v.3.6.1 and the latest RStudio v.1.2.1335 softwares.

I installed the package:

> install.packages("RcmdrPlugin.NMBU")

and everything went ok.
"package ‘RcmdrPlugin.NMBU’ successfully unpacked and MD5 sums checked"

When I try to load the library:

> library(RcmdrPlugin.NMBU)

this is what I get

Error: package or namespace load failed for 'RcmdrPlugin.NMBU':
 .onAttach failed in attachNamespace() for 'RcmdrPlugin.NMBU', details:
  call: mergeCapabilities(modelCapabilitiesList)
  error: redundant model class or classes in plug-in package model capabilities table
In addition: Warning messages:
1: In tclRequire("dde") : Tcl package 'dde' not found
2: In tclRequire("dde", warn = TRUE) : Tcl package 'dde' not found

Does anyone knows how to solve this issue?
I installed both softwares on another machine to check if was an issue with this machine (since I have removed and reinstalled the softwares to see if it would solve the issue), with no luck.

Any guidance would be helpful.

Thank you.


The possible solution is in the error message:
"Tcl package 'dde' not found".

Try downloading and installing the {dde} package first to see if that fixes it.


thank you for the reply.
I have been looking for this package and cannot find!
Could you please send me a link to the source if you have available.

You mentioned you are using RStudio. In which case, click on the "packages" tab (usually in the bottom-right pane if you have not changed the default layout).
Then click the "install" tab, and type-in the package name: "dde". It will fetch the package from the RStudio CRAN mirror by default unless you specify one closer to your location. You can do this in the Tools>Global Settings menu.

See if
library(RcmdrPlugin.NMBU) works, if not , try re-installing the {RcmdrPlugin.NMBU} package via the same route.


Thank you again Davo.
I reinstalled the "dde" and the "RcmdrPlugin.NMBU" packages... I still get an error message.

Error: package or namespace load failed for 'RcmdrPlugin.NMBU':
.onAttach failed in attachNamespace() for 'RcmdrPlugin.NMBU', details:
call: get(x, envir = RcmdrEnv(), mode = mode, inherits = FALSE)
error: object 'commanderWindow' not found

Sometimes the package "nmbu" (not "RcmdrPlugin.NMBU") runs and others it just doesn't.
Also, I was never able to run "RcmdrPlugin.NMBU" at all!

Very frustrating situation.

The penny has just dropped!!
You cannot run Rcmdr (R Commander) (or any Rcmdr plugins) from within RStudio.
Close RStudio, and run the simple Rgui.
library(Rcmdr) (say 'yes' to download any required packages).

Then, in the RCommander Window click on the menu "Tools>Load Rcmdr Plugins" and click on 'RcmdrPlugin.NMBU' (say yes to download packages if required).

You should now be ready to use the plugin facilities, but only there in the Rcmdr interface (not RStudio).


Hey David,
I wish I could stop bothering but even running RGui is not working.
I did as you have told me and I still get the same error message:

"Warning messages:
1: In tclRequire("dde") : Tcl package 'dde' not found
2: In tclRequire("dde", warn = TRUE) : Tcl package 'dde' not found
Error in structure(.External(.C_dotTclObjv, objv), class = "tclObj") :
[tcl] invalid command name "cget"."

So, I restarted the software and first installed the dde package, which went well, then tried running the NMBU under library(Rcmdr) from the RCommander tool window and I get the same c***! Tried only installing the RcmdrPlugin.NMBU... same c***!

I just feel like I am trying to solve the QCD Lagrangian equation using an abacus :frowning:

Is this a cosmic conspiracy?

Anyhow... if you know any other way/package to run a Post hoc pairwise comparison (Fisher/LSD) I would be pleased to try, because so far I think our good friends at NMBU don't want me using their plugin.

Thanks and Cheers.

This is a bit of a challenge!
You could check that your packages are being installed in an expected location:
.libPaths(). Other recently-downloaded packages are working, yes?

Check that the tcltk package is listed in the System Library. Try Packages>Update>All in RStudio (do it there for convenience).
Also install the tcltk2 package (the documentation mentions DDE capability).

Good luck.

Hi @Fabster!

The missing dde here is not an R package, but instead part of Tcl/Tk, which is the non-R software library that R Commander uses to create its GUI. So basically, it looks like some of the non-R system components that this R Commander plugin expects to be present are missing on your system. However, I can’t really tell if that’s the whole problem based on the error messages above (the mentions of dde were only warnings).

If you're determined to get this plugin working, I'd start by reviewing the R Commander installation notes and the documentation for the plugin itself.

However, if you're only going through all of this in order to do a Fisher's LSD test, then you definitely have other options! :grin: There is more than one R package out there that implements a Fisher's LSD, but a commonly used one is agricolae. This page has a nice example showing how to use its LSD.test() function: R Companion: One-way Anova

Just a note, this is not the case. R Commander is compatible with RStudio (though you'd be forgiven for not realizing this, since it's stated in a footnote on page 25 of the Rcmdr introductory manual :sweat_smile:).

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.