Help with error messages when trying to load dplyr in r studio please

I am trying to load dplyr but keep getting the same error message:

"> library(dplyr)
Error: package or namespace load failed for ‘dplyr’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
namespace ‘rlang’ 0.4.11 is already loaded, but >= 1.1.0 is required
In addition: Warning message:
package ‘dplyr’ was built under R version 3.6.3 "

I have tried to uninstall and reinstall "rlang" and "dplyr" but I still can't get it to work. Are there any suggestions?

I assume there was another error when you tried to re-install rlang, but I cant guess what it would have been.

It seems you are using a very old R version, so, unless you have some reproducibility constraints, I would recommend updating your R version and packages

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.