HELP: tidyverse had non-zero exit status

I used to use a Microsoft Surface, but it broke down. I just bought an Acer Chromebook today, and I am trying to get R and RStudio up and running on it. I need to install tidyverse, but it keeps saying it has a "non-zero exit status" and I have no clue what that means. I made sure I'm running Linux on my Chromebook, and I am able to open RStudio. My first course of action was to install tidyverse, but that's not going very well. Is there anything else I need to do? Thank you!

Hi, welcome!
Could you please post the whole error message you are getting? So far you are not giving us enough information to work with.

It says ERROR: dependencies "broom", "dyplr", "modelr", "tidyr" are not available for package 'tidyverse'

  • removing '/home/emilylnielson/R/x86_64-pc-linux-gnu-library/3.3/tidyverse'
    Warning in install.packages:
    installation of package 'tidyverse' had non-zero exit status

The download source packages are in

What happens if you try to install the missing dependencies?

install.packages("tidyverse", dependencies = TRUE)
1 Like

I tried it with both dependencies = TRUE and dependencies = FALSE and neither worked

Ok, but do you get any different message when you try with dependencies =TRUE?

It says the dependency "tidyr" is not available for the package "broom", and that "broom" and "tidyr" are not available for the package "modelr", and that "broom", "tidyr", "dyplr", "modelr" are not available for the package "tidyverse".

Ok, that is not telling us much, what happens if you manually try to install tidyr? Do you get any different message?


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.