Help: The online ShinyApp link (shinyapps.io) works on my side (PC) but doesn't work on my colleague side (Mac). Does anyone know the reason or how to figure it out? Thanks!

As the topic described.

What happens when your colleague clicks the link in a browser?

It just says "not found"

Have you tried the link on a third machine (or in a private/anonymous browser window on your machine)?

Yes. I tried it on others computer, and it works too. I don't know why it only doesn't work on my colleague's laptop....

A few more questions ...

  1. Is the "not found" error accompanied by a graphic of an upset automaton and the number 404?

  2. Is there anything in the URL besides "https://<account name>.shinyapps.io/<app name>/"?

  3. Does the app require a log in?

  1. It only shows "Not Found" error without anything else.
  2. Nothing else.
  3. Doesn't require the log in. Just get access to the link.

I don't suppose you can share the link here?

Has your colleague tried either a private browser window or a different browser on their computer (for instance, Chrome instead of Safari)?

Does the app load any files (read a spreadsheet or database) when it starts? The lack of anything besides "Not Found" suggests that the problem is not Posit failing to recognize the link. So apparently something other than the page itself is being "not found" ... unless maybe the Mac is being blocked from the Shinyapps server by a firewall or something.

Two other things you might look at come to mind. First, can the colleague's Mac access any other apps on shinyapps.io? That would rule out a firewall getting in the way. If it can, and assuming you are the "owner" of the app in question, you can log into your Shinyapps account, have the colleague try to run the app, then look in the server log (to which you will have access as account owner) and see if you can spot an error message there.

1 Like