Help on warning message "no font could be found for family 'Arial'"

Using a Mac with latest updates installed. In R and R Studio, I'm getting this warning message:

1: In axis(side = side, at = at, labels = labels, ...) :
no font could be found for family "Arial"

I've seen discussions of this problem in the past, but I have not seen a fix.


To help us help you, could you please prepare a reproducible example (reprex) illustrating your issue? Please have a look at this guide, to see how to create one:

> plot(cars, 
  xlab = "Speed (mph)", 
  ylab = "Stopping distance (ft)", 
las = 1, xlim = c(0, 25))

There were 39 warnings (use warnings() to see them)

When I run that code I don't have any errors or warnings (see reprex below).

The message;

is telling you that if you run warnings() in your console, R will report what those warning messages are. Also note that warnings don't necessarily stop your code. For details; R: Warning Messages

     xlab = "Speed (mph)", 
     ylab = "Stopping distance (ft)", 
     las = 1, xlim = c(0, 25))

Created on 2019-05-29 by the reprex package (v0.2.1)

Also note that this isn't a reprex. Here's a nice video that walks you through how to get that.
Reproducible examples are useful (if not essential) to diagnosing problems like this.

The problem has been solved.

For other Mac users who encounter this issue with R...

  1. Go to Finder
  2. Search for "Font Book" and open it.
  3. Look for the Arial font and, if it is greyed out, turn it on.

This eliminates the warning and enables R to produce the appropriate labels.

If your question's been answered (even by you!), would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it:

Yes. Will do. Thanks.

I hope the answer helps others.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.