Headaches installing dev version suite of tidyverse dependencies

This has steadily gotten worse for me over the last couple of years and I thought I'd see if anyone has advice or if I'm doing something wrong. Or maybe this is a Windows specific problem?

My steps today:

  1. Run Rgui exe as an administrator
  2. Try devtools::install_github("tidyverse/tidyverse") and say yes, I want to update all packages.
  3. It fails at fs, saying that the prior installation of fs cannot be removed. I can't install.packages or remove.packages it. I restart R. Because fs is a dependency of devtools, I can make no more progress.
  4. install.packages("fs") to get the CRAN version of fs. Go back to step 2.
  5. Some packages succeed, but same error for processx - it cannot be removed. Repeat step 4, go to step 2.
  6. installation of rlang fails though with a different, more complex error message. Restart R, try to load devtools, I get package ‘rlang’ does not have a namespace. Install rlang from CRAN.

Here I had problems with rlang locking the directory, culminating with the error message:

Error in file.copy(files, dest, overwrite = TRUE) :
(converted from warning) problem copying .\rlang.dll to C:\Users\SFirke\Documents\R\win-library\3.5\rlang\libs\x64\rlang.dll: Permission denied

I hoped running Rgui as an administrator would fix this permissions issue but it seems not to.

Do other users, particularly Windows users, have similar problems with devtools::install_github() in general and in particular navigating the current set of tidyverse dependencies?

I have an internal R package that uses tidyr::pivot_wider() but at this point others can't use it because they can't navigate the web of tidyverse GitHub dependencies. I'm looking at either refactoring the code or shelving the package until the next tidyr release.

I used to often use development versions of dplyr etc. to get the latest features but maybe that's an outmoded expectation. Thanks for guidance anyone can offer on this process.

There are a couple of issues here, I realize. The permission denied is referenced here though the solution isn't working for me. But the issue of say, fs terminating in a half-installed state is separate.

Have you tried manually deleting the folder and install again? This seems like a permissions misconfiguration for your windows user at the OS level.

Another thing to try is installing on a different libpath, e.g.

install.packages("fs", lib = "C:/Program Files/R/R-3.5.0/library")

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.