Have difficulty loading in 'Tidyverse

I've been working with Rstudio for last six months, but never had such issues. Earliar today, I had difficulty loading in 'Forecast' which I could just figure out with R Studio Community Help. Now, I just reinstalled R studio... tried to load in tidyverse, but wouldn't work. The errors reads:

Error: package or namespace load failed for ‘tidyverse’:
.onLoad failed in loadNamespace() for 'readr', details:
call: options()
error: Value of SET_STRING_ELT() must be a 'CHARSXP' not a 'NULL'
invalid option "error"

Note: I've already tried ' Install.packages ("tidyverse", dependencies = TRUE).

I'll appreciate if someone could help me with it. Thank you!!

And now when I tried to load in Tidyverse, it showed something else. This is what it reads to me now:

*** recursive gc invocation
*** recursive gc invocation
*** recursive gc invocation
Error: package or namespace load failed for ‘tidyverse’ in as.environment(where):
invalid object for 'as.environment'

Adding more, when I tried to install 'Tidyverse', it takes a lot of time to get installed. Just couple of days ago, things were as fast as lightening. I'll really appreciate if somebody could explain things for me, please. Thank you!!!

I'm having a similar issue. It just started happening randomly (not after an upgrade or anything). Reinstalling R and R Studio hasn't helped.

I tried this solution, but it didn't help:

I'm having a similar issue.

I solved this issue on my windows 7 by going to :
and then searching for "RStudio" by using the search box and deleting all folders and files that appear in the search result.

Sadly, this did not fix my problem.

Also, it seems like it is not related to Tidyverse stuff. It seems pretty random which packages fail to load properly. Now I'm getting errors with DESeq2. Again, this package loads fine when directly using the R terminal, so the problem is with R studio specifically.

I'm having this issue, as well. I don't see the error in base R--I only get it when using Rstudio. I updated the packages and updated Rstudio, but it still didn't work.

For me, sometimes it works, other times it doesn't. I really have no idea how to get it fixed... It's so annoying.. bc it keeps eating major chuncks of my day. :smiley:

1 Like

I opened an instance of base R using elevated permissions and updated all packages directly there.

For whatever reason that seemed to help.

Whenever I get the GC error (or something similar), I fully close R studio and then start it up again. This has reduced the frequency of these annoying errors.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.