Grey screen, but only when exiting a project. Software rendering doesn't help. Windows desktop.

EDIT to add a tl;dr: RStudio IDE runs fine when in a project, but if I try to run it without any project open I only get the grey screen and non-functioning menus. Software rendering doesn't fix it.

EDIT 2: If I wait ~65 seconds it opens up. See reply below.

Running RStudio Desktop IDE on a remote Windows computer accessed via RDC. At one point everything worked, but other people administer the system and things sometimes change, so I may have to investigate further with them based on discussion here.

The issue now is I can only open RStudio in certain situations, usually by navigating with Windows Explorer to a ".Rproj" project file and double-clicking that. Once that opens the IDE if I choose to "Close project" I get the dreaded grey screen of uselessness. If I instead close RStudio while it is currently functioning with a project open, it will open successfully the next time I open the program directly (without having to click an Rproj file), but if I get the grey screen I have to force-close the program, and the next time I try to open the program I get the grey screen again, so instead I have to go back to double-clicking an Rproj file.

The usual suggestion here for the grey screen is to hold Ctrl while opening the program and selecting software rendering, but neither that nor any other option available in that method changed anything. Again, it only happens when I try to close a project, i.e. when I try to run RStudio without a project active.

Quirks of the setup:
[EDIT 3: these first two points don't seem to matter, I created test projects in other locations and they all function normally, it is only Project: (none) that has an issue.]

  • We have an additional storage drive where I keep projects, lets call it "G:/", so for my global RStudio config I have the project directory root set to something like "G:/brian"
  • As per usual, though, my default home ("~") is like "C:/Users/brian/Documents"
  • We have to use a proxy for internet connections, but I've tried with that both on and off and the behavior is the same. I mention this though because it is the thing we most recently tinkered with, for non-R reasons.

So I tried exercising some patience, and it turns out if I wait about 60-65 seconds the IDE finally fully opens and is fine. Of course it would be nice to not have to wait that long each time, but maybe this helps identify the issue.

I can get this to happen consistently every time when trying to switch to "Project: (none)". Whether that be by closing an open project or by restarting RStudio where it restores the state when I had closed it, and if it had been on Project: (none) when it was closed then re-opening it takes that extra 60-65 seconds. When RStudio does open I can switch to other projects normally, but closing a project (returning to Project: (none)) causes that 60-65 second grey screen delay. I can do this repeatedly and it occurs consistently every time when switching to Project: (none).

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.