Graphics API version mismatch after update to R version 4.2.2

After update R to 4.2.2 and shiny package to 1.7.4, when I launch the default shiny app (Old Faithful Geyser Data), it showed "Graphics API version mismatch".

Do you happen to run the default shiny app within RStudio IDE by any chance ? If so, which version ? You may want to update R Studio to a more recent version to make sure the R <==> IDE integration is still working.

IF this does not help, please report back with more details on how you get to the "Graphics API version mismatch".

I'm running the default shiny app on RStudio 2022.12.0 Build 353. Below is the version detail.

RStudio 2022.12.0+353 "Elsbeth Geranium" Release (7d165dcfc1b6d300eb247738db2c7076234f6ef0, 2022-12-03) for Windows
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) RStudio/2022.12.0+353 Chrome/102.0.5005.167 Electron/19.1.3 Safari/537.36

The error occur when I create new shiny web app and run the default app (Geyser). It worked fine before I update.

I follow the answer from the link below by removing and re-installing the package ragg. Not sure why but now it works.

Getting the Error: Graphics API version mismatch

1 Like

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.