git disappeared from the RStudio IDE

All of a sudden, out of nowhere, Git disappears. R can't seem to find it, and the Git tab in a project is gone.

I reinstalled RStudio & Git (which went to a different path location on the reinstall) and then pointed RStudio to the correct (new) Git path. Now it works. (Currently RStudio 1.2.5001, Git 2.23.0, but these are both new with the problem solved.) I'm working on a Mac Mojave 10.14.6.

However, I teach a class of 35 students where the Git-RStudio combination happens every day (for turning in assignments), and now my students have the exact same problem.

The most likely cause is an Xcode update. After updating Xcode, you need to agree to the new command line tools license agreement. Try running this in the terminal:

/usr/bin/git --version

You should get prompted to read and agree to the license agreement, and after this command line tools should again be functional.

1 Like

Thanks for the reply! I have already done too many things (including updating license agreements) to know if this is the exact solution. My git is now working just fine. If I have more students with the problem, I'll send them to this solution with fingers crossed. I appreciate the help!!


1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.