Getting error while installing a package

Hi all,

I'm getting below error while installing a package. can anyone please help me how to fix this problem?

Error: package or namespace load failed for 'ggplot2' in library.dynam(lib, package, package.lib):
DLL 'colorspace' not found: maybe not installed for this architecture?

Which script did you use?

My bad, I am getting error while installing package. Even I have deleted these packages and try to install it again but the issue is not fixed yet.

Which version of R did you install?

This is asking you to install the colorspace package.


If you get any error message while doing so, post it here so we can take a look.

1 Like

A post was split to a new topic: Problem installing the getSpatialData package

I tried to install the above package but I'm getting the below error:

Error: package or namespace load failed for 'ggplot2' in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
there is no package called 'colorspace

As I said, this is asking you to to install the colorspace package. If you have already tried to install it and you keep getting the same error message while trying to load ggplot2 then something has gone wrong.

Run this command in your R console and post the complete console output you get.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.