Get the administrator role for some users on rstudio connect


I am currently experiencing the following problem on my Rstudio Connect environment:
In the past, we used our last name to authenticate.
Recently, we have been using SAML authentication and we use our VISA number.
So we currently have two accounts :

  • an account identified by the family name
  • an account identified by the VISA number

The problem is that I used to be an administrator, but since the authentication change, my new account does not have the administrator role.

I would like to change the status of my current account (identified by my VISA) to administrator, but since I no longer have access to my old administrator account (identified by my last name), I don't know how to proceed.

Can you please help me?

Oh no! Howdy @alain!

I very much hope you resolved this issue by now :see_no_evil:

To fix this issue, there are two remedies:

  • "migrate your old user": list accounts with usermanager list, delete your new account with usermanager delete and then alter your old account to have a "new unique id" that matches your new account: usermanager alter --user-guid {{old-user-guid}} --new-unique-id {{my-unique-id}}
  • "change role": The usermanager CLI is always a get-out-of-jail-free card :smile: usermanager alter --user-guid {{old-user-guid}} --new-role administrator

I hope that helps! Either you or someone else who runs into this problem!

Helo @cole !
I just saw your answer.
I was able to find the solution but thanks for the help.

See you soon :smiley:

1 Like

I have the same problem. After I installed Connect I registered and logged in. Then we added saml support, so I have a new user-id, which is viewer. I need to make it administrator. When I use the "alter --user-guid xxx --new-role administrator, I get the message that tells me user roles are managed by saml and cannot be altered. How do I get around this problem/

Ugh. That is a painful error :sob: I'll push this upstream and see if we can change this behavior in the product.

This is a pretty janky workaround, but I think it should work:

  • Turn off Connect
  • Edit config file to Authentication.Provider = password
  • Run usermanager to make you an administrator
  • Edit config file to Authentication.Provider = saml again
  • Start Connect

Would that work for you?