Function 'descdist' works in RGui but not in RStudio

You might think I'm in the wrong category but the code below runs fine in the RGui but doesn't provide a plot in RStudio. When the code is run, RStudio provides the numerical output, but doesn't provide a graph and the computer's processor is stuck at a high power usage. I tried restarting the computer but that didn't help the outcome of the code. This is a function I use once in a while and it ran fine in the past.
I use the following R version 4.4.0 & Rstudio version 2024.04.1 Build 748.

Do I make a mistake?

Thank you for your help.

I copied the code from:

x <- c(37.50,46.79,48.30,46.04,43.40,39.25,38.49,49.51,40.38,36.98,40.00,
fitdistrplus::descdist(x, discrete = FALSE)

After I upgraded to the latest version of RStudio, there are strange bugs in several windows in the lower right corner, I think it's a problem with the latest version of RStudio, my shapley diagrams don't show up fully and the GWalkr package doesn't wake up the shiny window directly.

1 Like

I'd anyways suggest you re-run it, I had no problem running your code, but mine came up as unable to ! image|690x369 to resolve the issue

1 Like

works here

[1] "2024.04.1+748"

1 Like

Thank you for your help.
I just ran the code on a personal laptop with the same R and RStudio version. That worked without an error. Maybe it is some kind of graphical issue. Tomorrow morning I will rerun the script on my company laptop that has different settings for graphics.

I think I found the issue. A few years ago, I wanted to use the font Helvetica. Therefore I downloaded packages 'systemfonts' and 'ragg'. Next, selected 'Tools > Global Options' from Posit’s main menu bar. Clicked the 'Graphics' menu at the top of the interface and, under the Backend option, I selected 'AGG' . This change should ensure that Posit renders the previews of any plots with the ragg package.

By setting the Backend option to '(Default)' I'm able to plot the Cullen and Frey graph. And when I set it back to 'Agg', Posit hangs (processor keeps working at high power consumption but nothing happens).

Thank you for your help.

Is there a way to inform Posit's software development team about this issue? it looks like a bug I can reproduce and fix. I could inform one of the administrators.

Can confirm, if I switch to AGG, it hangs. Cairoand Quartz work.

1 Like

Hi @Gerard1 -

The best way to file a bug would be to do so here:

Be sure to link back to this thread for the additional details of what you tried.


1 Like

Thank you.
I submitted a bug report on GitHub and included the link to this discussion.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.