Fresh R Studio Desktop Install Will Not Open on MacOS Catalina

I am in need of some help because I am not able to get a new installation of R studio to open on my computer. I've been using R studio daily, but I needed to update my R version to load some packages in old code I was re-running, so I did that successfully. Then, my R studio gave me a message that "R graphics engine version 14 is not supported by this version of RStudio." Even though when I checked for updates, it said that there weren't any, I decided to uninstall and re-install the most recent version of R studio. This is where my problem started - when I tried to launch R studio, the icon just bounced for a couple of minutes and then the app froze and would not open. I've tried uninstalling and re-installing, restarting my computer, checking "which R" in Terminal as I saw suggested on an earlier thread, but nothing is working. Please help!

My system:
MacOS Catalina (10.15.2)
2.7 GHz Quad-Core Intel Core i7

R version 4.1.1 downloaded from: R for macOS (I chose the first option since I don't have Big Sur)

R studio downloaded from: Download the RStudio IDE - RStudio (MacOS 10.14+)

Please let me know if you need any additional information about my system and programs!

Hi -- sorry for not being clear in my explanation! When I run:

which R

I get


Which was one of the suggested troubleshooting steps in one of the threads I read, to make sure it wasn't being masked by something like Anaconda. I also wanted to try the steps here: Rstudio desktop freezes upon startup But I can't find those directories on my computer.

R itself works just fine. I am wondering if R studio is trying to restart from some previously saved workspace as the R terminal says: "Workspace restored from /Users/elisehickman/.RData." When I go to this folder, I have multile .RData files there - I think I'll try moving/deleting them and seeing what happens.

When I moved those .RData files, the R terminal is still trying to open previous workspaces when I quit it and relaunch it. Very weird, not sure how to proceed!

I have R set to ask whether or not I want to save the workspace. I also really have no idea why it is not working. I've tried uninstalling and re-installing multiple times, as well as manually removing some files. I also tried updating my operating system to Big Sur, to no avail. Thanks for your input though!

I'm having a very similar sounding issue with RStudio on my PC that is running Windows 10. The program simply stopped working and I couldn't load it at all. I've also tried all the suggested fixes you've listed. The only thing that has worked is reverting to RStudio version 1.1.463, which works fine, even with the latest version of R (4.1.1). I can't view plots directly in that version of RStudio because R Graphics engine 14 is not supported, but I'm not finding that too much of a problem as I can save the plots and view them externally. I'm surprised though that nobody so far seems to have any further clues on this. I've spent a lot of time on it in the last week or so - so far to no avail.

1 Like

same problem.
I resolved by install old version RStudio Desktop 1.3.1093: Older Versions of RStudio - RStudio

I was finally able to get RStudio to work! Not sure this fix will help anyone else, but I'll share it just in case. It turns out there was a popup on my computer asking whether it was okay to open RStudio since it was downloaded from the internet. Unfortunately this popup was off-screen and also hidden by another popup error I've been having issues with on my computer that I needed to clear first. Thanks all for the input!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.